
 
 
 
 
 
 

New Features in  
TurboCAD v16 

 
 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

Quick Pull ...............................................................................................388 
Part Tree................................................................................................389 
Extrude to Face........................................................................................390 
Thread...................................................................................................394 
Twisted Extrude .......................................................................................397 
Component Wall .......................................................................................399 
Adding a New Wall Component .....................................................................401 
Using the Viewing Panel..............................................................................403 
Saving the New Component Wall Style.............................................................404 

 



New Features in TurboCAD v16 
 

388TurboCAD 3D Training Guide  New Features 
  

What's New in TurboCAD 16 

 The following  are a few new features which have been incorporated into TurboCAD v16 
Professional and which are relevant to users of this TurboCAD 3D Training Guide. 

 For New and Improved 2D features, please refer to the TurboCAD 2D Training Guide. 
 

 

 

Quick Pull 
Insert > 3D Object > Quick Pull 

 This tool allows for the planar extrusion of a face of a solid, either as a quick modeling 
function, or by a specific extrusion height/depth. 

 Modeling features such as draft angle, fillet blends and chamfers can be applied to the new 
extruded face. 

 The Part Tree records all extrusions created using Quick Pull tool as an Imprint and allows 
future modifications to be done using the relevant Part information in the Selection Info 
Palette. 

 
 
 
 
 
 
 
 
 
 

 Draw a 3D box to measurements 100 x 80 x 50, shown right.  The face shown shaded will be 
extruded to an additional outward height of 40. 

 

 From the 3D Object menu panel select the Quick Pull 
tool and select the indicated face, shown right. 

 

 TAB to the height field and input a value of 40. 

 

 Next, a tapered extrusion of 15º will be applied to the 
face indicated below, with a new extrusion distance of 
40. 
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 Select the Quick Pull tool, right click and apply 
a draft angle of 15º in the Extrude Shape 
options. 

 Now select the face shown above and extrude 
to a new outward distance of 40 so that the 
result is similar to the illustration, right. 

 

 

 

 

 

 

 
  

Using the Part Tree to modify a solid 
View > Selection Info Palette 

 

 In the illustration below, the part has been selected and the information presented in the 
Selection Info Palette as PartTree components.  In this example, the tapered extrusion is 
shown  selected and highlighted. 

 A Fillet with a radius of 5 will now be applied to the top edge of the new tapered extrusion by 
modifying the data in the Selection Info Palette. 
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 Select the tapered extrusion part in the Selection Info palette, 
shown on the previous page, then select the Fillet option in the 
Top Blend Type field, shown right. 

 Input a value of 5 to the Top Blend Radius.  The result is 
shown right. 

 

 
 

 

Extrude to Face 
Insert > 3D Object > Extrude to Face 

 This extrusion tool allows selected faces of solids to be extruded so that they intersect the 
face of the selected body, either adding or subtracting material during the extrusion. 

 Two faces can be extruded bi-directionally by selecting 2 faces in the same plane. 
 
 

 In this example, a 3D Box to measurements 
100 x 80 x 20 has been drawn, then shelled 
out by creating an inner wall thickness of 2.  
The top and bottom faces were excluded from 
the shell function, shown below. 
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 A smaller profile has been drawn and placed in 
the interior of the box and a simple extrusion of 
2 has been provided for the smaller profile. 

 The illustrations below indicate clearly the 
position of the smaller solid in relation to the 
main solid body. 

 

 

 
 
 

 

 

Side View Front View 

 
 

 

 The 3D Add function shown above is the 
default option for the Extrude to Face tool . 

 To extrude the profile shown right so that it 
intersects with the body of the box and 
combines (3D Adds) its volume with that of 
the primary solid, select the Extrude to Face 
tool from the 3D Object menu.   

 Select the indicated face, then select the 
box. 
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 The result is shown below. 

 
  

Selecting 2 Faces to Extrude  
 

 Two faces in the same plane can be extruded 
bi-directionally to extrude opposing faces to 
the body of the solid. 

 In this example, both sides of the smaller 
extrusion were selected using the SHIFT tool. 

 Both faces were then extruded bi-directionally 
using the default Add option to combine the 
volumes of the shapes, shown below. 
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Using the Subtract option 
 In this example, the Subtract option was 
used to create an extrusion of the face 
shown right to the body of the primary 
solid. 

 The result is shown below. 
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Thread 
Insert > 3D Object > Thread 

 This tool applies a thread to a cylindrical face of an object by defining the pitch and the 
length of the thread. 

 Internal threads can be created when a cylindrical shape is subtracted from the body of a 
solid. 

 The Part Tree retains the individual history of both the thread and the cylinder and can be 
modified by means of the Selection Info Palette. 

 

 

 
 

 The Thread tool will apply either a Schematic (diagramatic), Simple or 
Genuine Thread to a pre-drawn cylinder. 

 In this example, a cylinder with a radius of 10 and a height of 50 is drawn, 
shown right. 

 Select the Thread tool from the 3D Object menu and select the Simple 
option, shown above. 

 Input 3 into the Pitch field, then select the top face of the cylinder shown 
below left. 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Next, select the cylindrical body of the cylinder shown above right.  
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 Now use the cursor to indicate the approximate threaded length 
similar to the illustration right.  In this example, a threaded length of 
30 was used. 

 The result is shown below. 

 

   

 

 
 In this example, a thread will be added to the interior of 
the cylinder shown right.  

 A 3D box of 30 x 20 x 10 was drawn.  A cylinder was then 
drawn from the bottom face of the box to a radius of 5 
and a height of 10.  The cylinder was then subtracted 
from the volume of the box. 

 Select the Thread tool and activate the Simple option.  
Set the Pitch to 2 then select the top planar face of the 
combined solid, then the interior surface of the cylinder, 
shown below. 

    
 

 

 

 

 

 

 

 

 

 Now indicate an approximate threaded length, similar to the illustration above right.   
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 The result is shown right.  

 
 The Selection Info palette is used to modify any 
component of the new thread.  For example, the 
compound solid has been selected, shown below and 
each component in the Part Tree retains its original 
design parameters. 

 Any value can now be updated in the Part Tree fields 
and such changes will automatically be reflected in each 
modified component.  
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Twisted Extrude 
Insert > 3D Object > Twisted Extrude 

 The Twisted Extrusion tool extrudes a profile perpendicular to the workplane to create a solid 
object, allowing modeling features such as twisting and tapering to be created. 

 This extrusion tool can create a bi-directional above/below workplane extrusion and modeling 
features such as a twist or taper can be applied at any position along the length of the 
extrusion. 

 The Selection Info Palette is used to modify the individual modeling features of the extrusion. 
 
 

 In this example, a 2D Polygon is drawn using the following measurement information : 

 
 An initial extrusion height of 100 with a twist of 90º starting from the 
bottom of the extrusion and ending halfway up the extrusion will be 
produced, similar to the illustration, right.  

 Select the Twisted Extrude tool from the 3D Objects menu, then right 
click and apply the following settings :  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Next, a draft angle (extrusion taper) of 15º will be applied from 
the top of the twisted portion (50) to the top of the extrusion 
(100), similar to the illustration, right. 
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 Make sure the Selection Info Palette is activated (Ctrl-
Shift-I) then select the extrusion so that the 
properties are shown in the Selection Info palette, 
right. 

  

 Next, the Selection Info palette will be used to create 
an extruded rod with a twist midway up the 
extrusion.  The extrusion height will be changed to 
90, with the twist starting at 30 and ending at 60.  
The twist angle will be set to 90º, shown right. 

 The result is shown in the illustrations below. 
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Component Walls 
 

 A wall consisting of multiple components can be drawn using the standard Wall tool and 
using the Style Manager to add additional wall components. 

 All components of walls are modified using the Style Manager and walls with specific 
components can be saved as a new style. 

 
 
 

 In this example, 3 components of a standard wall will be created.  The standard walls are 
drawn using the Architectural Wall tool and any conditions can be preset by right clicking onto 
the tool prior to drawing. 

 In this example, a standard wall width (thickness) of 220 was preset, with a height of 1800. 

 The Style Manager Palette is accessed from the View menu. 
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 First draw a small section of wall similar to the illustration 
right. 

 Open the Styles Manager palette and click onto the Wall 
Styles > Standard item. 

 This wall consists of 1 component at this stage. Change the 
name of this first component to Sheet Rock, shown below. 

 

 
 
 

 
 Now input 20 into the width field, unchecking 
the Plus Wall Width and Edge Offset options, 
shown right. 

 Input a suitable hatch pattern and pen color, 
similar to the illustration below.  Adjust the 
hatch pattern scale accordingly. 
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Adding a New Wall Component  
 

 First slide the bottom compartment of 
the Style Manager palette so that the 
representation of the walls is shown, 
illustrated right. 

 To add another component to the 
existing wall structure, input 2 into the 
Component value field, shown right. 

 Name this wall Insulation, creating a 
wall width of 150, unchecking the Plus 
Wall Width but inputting a value of 20 
into the Edge Offset field. 

 Apply a suitable Brush Pattern, Scale 
and Color, similar to the illustration 
right. 

 
 
 
 
 

 
 

 

 At present, 2 components of the wall 
have been created, shown right.   
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 To add another component, change the value of 2 to 3 and create another wall using the 
following information : 

 

Wall Name : Bricks 
Wall Width : 50 
Edge Offset : 170 (the total width of the previous 2 components) 
Uncheck the Plus Wall Width option 
Create a suitable brickwork pattern and color. 

 
 The result should be similar to the illustration 
right. 

 There should be 3 component walls at this stage, 
shown in the illustration, below.  
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Using the Viewing Panel 
 The walls can be viewed in the viewing 
panel of the Styles Manager by right 
clicking into the viewing panel and 
selecting a suitable view, similar to the 
illustration right. 

 The zoom magnification can be 
increased by targeting the required 
center of the zoom, and using the left 
click tool, similar to the illustration 
below. 
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 A Component Wall Style can be saved to the Style Manager for future use by selecting the 
Create New Style option, shown right. 

 Input a suitable name to store this style for future use. 
 When drawing a new wall with these features, first right click onto the Wall tool in the 
Architectural menu panel, and select the new Wall Style from the General page. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Saving the New Component Wall Style 
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